# Running Tendermint in aws ec2 instances

**URL:** <https://forum.cosmos.network/t/running-tendermint-in-aws-ec2-instances/3399>\
**Category:** Tendermint\
**Created:** [March 10, 2020, 11:43pm UTC](https://forum.cosmos.network/t/running-tendermint-in-aws-ec2-instances/3399 "2020-03-10T23:43:22Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![thangasblockchain](https://avatars.discourse-cdn.com/v4/letter/t/e0b2c6/32.png) [@thangasblockchain](https://forum.cosmos.network/u/thangasblockchain)\
**Post date:** [March 10, 2020, 11:43pm UTC](https://forum.cosmos.network/t/running-tendermint-in-aws-ec2-instances/3399/1 "2020-03-10T23:43:22Z")

</div>

I am trying to run Tendermint in distributed mode, in two Instances of aws ec2 (master and slave).  
I have added the ‘node id’ of slave into master instance in seeds.

whenever I try to start ‘Tendermint node’, it is throwing this error :

abci.socketClient failed to connect to tcp://127.0.0.1:26658. Retrying… module=abci-client connection=query err=“dial tcp 127.0.0.1:26658: connect: connection refused”

I have added the port 26658 to firewall. kindly help me on this…
