Signup/Login problem to https://forum.cosmos.network

I’m brand new to Cosmos. The first thing I tried to do when I found forum.cosmos.network was click the “Sign Up” button that I saw. I use both Google and Github, so in theory, I should be able to log in with either. I tried clicking the “with Google” button first. I got this 400 server error: https://drive.google.com/open?id=1wMqQO04GuIaPLPGNG2Hgp84FzNtKzT2q Smh.

I figured maybe I’d logged into it previously, so this time around I clicked “Sign Up”, followed by “with Github”. I thought for sure I saw another 400 error a few mins ago. By the time I tried entering this message and tried to reproduce it, it’s no longer doing it.

Either there was a temporary problem with oauth, or I’m tired and should stop right now. In any case, rather than search the forums for oauth to find out, I’ll gently ask: has there been some kinda weird problems with oauth recently? Asking this way will put my name on the books to show my history here. I could just search the forums and find the answer about recent oauth problems.

Turns out that I did already previously sign up an account on https://forum.cosmos.network/ using my email and a random generated password. Never thought to check my KeePassXC before attempting to log in with oauth.

Seems that if there was a problem with oauth and there was already a matching account that I absentmindedly created with my email and a password, instead of getting some ugly 400 error, there should be more informative error message like, “an account already exists with this username, please log in using your password”.

It’s entirely possible that this is all my fault somehow. I’m too tired to figure out whether that’s the case or not. Feel free to say I’m an idiot, or say there’s been a recent problem with oauth. And with that, I’m going to go get some sleep.