New nameservice app

#1

Hello guys. I am trying to set up a nameservice app, so as to understand deeply how it works, but when I tried to ran “make install” command, the cmd terminal throws:

github.com/user/projectrepo/x/nameservice

x\nameservice\types.go:4:2: imported and not used: “fmt”
x\nameservice\types.go:5:2: imported and not used: “strings”
make: *** [install] Error 2

0 Likes

#2

Is that a private repo?

0 Likes

#3

Hello. It’s a public Github repo. https://github.com/McDaan/Synthesis

By now I have been able to init the blockchain as a nameservice, and there have been flux of blocks, but since that point, I do not know how I should proceed in order to build entirely, so as to allow validators, delegators, etc.

Should I fork Cosmos SDK and Tendermint repos?

I am a bit confused about how I should proceed.

Cheers.

0 Likes

#4

Hey @Dany

Sorry about that, the instructions often get out of sync when we make an update to the tutorial. I’ve just made a PR with the patch at:


you can see that the importing of fmt and strings should be removed from the types file now.

let me know if you run into any more trouble!

0 Likes

#5

Hello @okwme
Thank you for your response.

I finally ran “make install” successfully, although I had to delete go.mod and go.sum, and change them to Gopkg.toml.

I successfully ran “nsd start” as well, and the flux of blocks started. Btw, how can I configure peers? Should I run another node? How could I know what’s the correct ports to use?

My main idea is to create a DappChain with its own native coin, so as to use it in the staking, governance, etc. Am I in the right way? How can I define supply, etc?

Regards

0 Likes

#6

Hi Dany,
We’re preparing a new tutorial for a basic dapp chain very soon, should have info about all of this.
If you are interested in running a chain that has those characteristics of the Cosmos chain you can just run the gaiad client with a custom genesis file!

0 Likes