Voting power 0 and not jailed


#1

Hi Guys,

Today I tried to bond with gaiacli tx create-validator --amount=50steak --pubkey=$(gaiad tendermint show-validator) --moniker=“Crytter” --chain-id=gaia-9001 --from=crytter --commission-rate=“0.10” --commission-max-rate=“0.20” --commission-max-change-rate=“0.01”

Seemed to go alright, however I have voting power 0 when running gaiacli status. I can see I’m appearing in figment however I’m not voting it seems.

Also gaiacli query tendermint-validator-set | grep “$(gaiad tendermint show-validator)” gives nothing. When checking the gaiad log it seems its prevoting just fine.

Has this happened to anyone before? Thx.


#2

Make sure you read the right priv_validator.json with gaiad tendermint show-validator. gaiad tendermint show-validator defaults read the home directory of your current user. If you are running your node using another system user, you are creating a validator with the wrong pub key. If this is the case, copy the priv_validator.json in your home directory to the home the user who is responsible for running gaiad start.


#3

that solved my issue indeed, thx kwunyeung!!