Can't install gaia

#1

I have just started testing the cosmos-sdk but i have a problem while installing Gaia .

I have installed go1.12.1 and modify the path as described in the documentation

echo "export GOPATH=$HOME/go" >> ~/.bash_profile
echo "export GOBIN=$GOPATH/bin" >> ~/.bash_profile
echo "export PATH=$PATH:$GOBIN" >> ~/.bash_profile

but I got this error while running make tools install

–> Generating vendor directory via dep ensure
make: dep: Command not found
Makefile:129: recipe for target ‘vendor-deps’ failed
make: *** [vendor-deps] Error 127

note ::: ~/go/bin$ ls
dep go goimports gometalinter statik

ANY HELP !!! :slight_smile:

0 Likes

#2

What OS and version are you using ? I also cannot build gaia from source. I am using Windows 10 and tried both Mingw and the Unbuntu Linox distro that is bundled with Win10 with no luck …

What worries me the most is that at the moment there is no binaries officially available, so to build from source is a requirement. And the official documentation does not even mention which systems are supported ! Commands look like bash commands executed on Linux, but nowhere is this mentioned (https://cosmos.network/docs/gaia/installation.html#install-gaia). No mention of Windows support in particular.

I find this very unprofessional and is quite worrying for me. Hope the team will answer soon as it is also quite worrying they did not answer you yet !

0 Likes

#3

I have tested it on windows10 and ubuntu 16.04 and i get the same error !!!

0 Likes

#4

I found the issue, this is PATH that was not properly set. I suspect this set of command does not work as expected :

echo “export GOPATH=$HOME/go” >> ~/.bash_profile
echo “export GOBIN=$GOPATH/bin” >> ~/.bash_profile
echo “export PATH=$PATH:$GOBIN” >> ~/.bash_profile
source ~/.bash_profile

because doing a fresh install, at the end GOBIN was not correctly set in PATH. I had to fix it manually

0 Likes

#5

I’m also running into issues installing on Ubuntu 16.04. Specifically:

/tmp/go-build593458668/b341/_x002.o: In function get_usb_string':* *vendor/github.com/zondax/hid/hidapi/libusb/hid.c:444: undefined reference tolibiconv_open’

Any advice is appreciated. I’ll respond if I fix it.

0 Likes