Tutorial fails build

I’m following the directions on liquidity module (Liquidity Module | Cosmos SDK Tutorials) and after the make install step, I get the following output:

mkdir -p /Users/ekkis/dev/gravity-dex/build/
go install -mod=readonly -tags “netgo ledger” -ldflags ‘-X github/cosmos/cosmos-sdk/version.Name=gaia -X github-com/cosmos/cosmos-sdk/version.AppName=gaiad -X github-com/cosmos/cosmos-sdk/version.Version=add-liquidity-module-to-gaia-fd6bb727660a052bc1e702325acd28b02dfd6a39 -X github-com/cosmos/cosmos-sdk/version.Commit=fd6bb727660a052bc1e702325acd28b02dfd6a39 -X “github-com/cosmos/cosmos-sdk/version.BuildTags=netgo,ledger” -X github-com/tendermint/tendermint/version.TMCoreSemVer=v0.34.10 -w -s’ -trimpath ./…
go: downloading github-com/cosmos/cosmos-sdk v0.42.5
[…]
go: downloading github-com/gtank/ristretto255 v0.1.2
go: downloading github-com/mimoo/StrobeGo v0.0.0-20181016162300-f8f6d4d2b643
go: downloading github-com/zondax/hid v0.9.0
github-com/keybase/go-keychain
cgo-gcc-prolog:203:11: warning: ‘SecTrustedApplicationCreateFromPath’ is deprecated: first deprecated in macOS 10.15 - No longer supported [-Wdeprecated-declarations]]
/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/Security.framework/Headers/SecTrustedApplication.h:59:10: note: ‘SecTrustedApplicationCreateFromPath’ has been explicitly marked deprecated here

and then when I execute the next command gaiad version I get the error:

-sh: gaiad: command not found

this is my uname -a:

Darwin katallaxia 20.5.0 Darwin Kernel Version 20.5.0: Sat May 8 05:10:33 PDT 2021; root:xnu-7195.121.3~9/RELEASE_X86_64 x86_64

and I have the latest version of go as I just installed it. can anyone help me?

p.s. I’ve had to replace all the github.com references to github-com as otherwise the forum won’t let me post the message

it’s been 18 days since I posted. it’s clear I will not receive any help getting the simplest of tutorials to build. it’s equally clear that there is no developer support. it’s a pity. I wanted to develop on Cosmos, but zero chance I will do so when there is no support

I will find an alternative platform. there are many.

I think this forum has very little activity. Iiuc, the discord is a more active, and the preferred, place for development help: Cosmos Developers

thanks but I’ve had zero luck there too

I believe go install will put binaries in your $GOPATH/bin, where $GOPATH should be $HOME/go by default if you haven’t set it to something else. It seems like maybe you need to add that directory (eg. $HOME/go/bin) to your $PATH so your shell can find the binary? See The default GOPATH · rakyll.org for more info!

The issue is related to building a dependency. It seams the go-keychain is failing to compile. Maybe something related to C compiler defaults on Mac?

@ekkis which repository did you clone? Is there a Makefile in /Users/ekkis/dev/gravity-dex? If yes, try make build in the project root directory (and install make / build-essential if you don’t have it).

I used the one indicated in the tutorial: git clone https://github.com/cosmos/gaia && cd gaia, and yes, there is a Makefile in that directory

Jiminy Christmas. I might have known that were I a “go” guy, but that solved my problem. the compilation worked, it just produced the binary in a place I wouldn’t have known to look. it’s voodoo

a thousand thanks!

I would close this ticket but I guess this site doesn’t understand the concept of closing a ticket, or it does but makes it completely unintuitive to the user. sigh…

incidentally, the version from gaiad doesn’t look anything like what I’d expect:

$ gaiad version
add-liquidity-module-to-gaia-fd6bb727660a052bc1e702325acd28b02dfd6a39