IBC transfer with Relay ON


#1

I was testing IBC with basecoin app.
I setup two different chains, and created account for each.
First I executed the transfer command which subtracted coins from the source account.
Then I executed the relay command which confirms that message got received and the coins added to destination account in the destination chain.

Now the relay runs in a loop. I tried to execute another transfer with relay running, so that coins get added to destination account just after transfer is complete. But then I got the message ‘no keybase found’

Is there any workaround this.(any possible fixes in the code also?)
Is this how this supposed to work?(ie For each transfer a relay command to be executed).

Also I observed that If relay fails for some reason the coins subtracted from the source doesn’t get added to destination account. So are the coins just lost?

I was following this https://github.com/cosmos/cosmos-sdk/blob/master/x/ibc/client/cli/README.md


#2

I was using the same keybase for both the chains. Keeping separate keybases solved for the chains solved the issue