Trouble Delegating with a Nano Ledger S

Utilizing a properly configured Nano Ledger S (in dev mode, latest firmware, latest Cosmos software), I am having trouble doing the final “Signature” to stake ATOM to a validator.

I have a test 571 ATOM appearing on, I go to your validator page, push the delegate button, and that is where things start to getting funky on several of my windows 10 machines.

  • I get an unstable flashing of the windows 10 “Making sure it is You” alert,
  • Then I get the same type of Windows 10 alert saying “touch your device” (flashing more unstable)
  • At that point, I do the two button push on the ledger and the transaction shows on the face of the Nano ledgers properly,
  • I scroll to “sign transaction” on the Ledger and I two button punch the “sign” confirmation, and get the Windows 10 alert - “Couldn’t Complete Sign in”.
  • I have tried updating the ledger driver (not available)
  • The Windows defender is turned off (I use trendmicro & have added as a trusted site)

Have you all heard of this issue, and any solution to it?

If any one is curious, I got an email from Fabo at, there is an issue with the latest update of Win 10 and Nano ledgers. It looks to me like they want to treat a ledger ad a Yubi key.

Solved somewhat.

After updating my dual boot, win 10 / win 7 machine, I was able to delegate in win 7.

Before the update, the win 7 didn’t see the Nano ledger S, after the update it appeared, but still couldn’t find the driver - it worked once you saw it in devices.

Now validators, if I were you, I’d be getting on Ledger to fix this issue - it has got to be taking a bite out of people who want to stake from a ledger.