My 12 word seed phrase from fundraiser is not working, please help

#1

Hi,

My 12 word seed phrase from the fundraiser is not working. Here’s what happened so far:

  1. I wrote it down and didn’t touch it for the two years
  2. I tried to enter it into my nano ledger s and it said invalid recovery phrase
  3. so i went on an offline computer and entered it into the cosmos-cli tool, and the cosmos address that gets returned is not the same as the one I have written down, and that was published in the ETH fundraiser contract, and has atoms allocated to it.

Most likely, I have messy writing, and I wrote down a word that doesn’t look like it should. However, I tried many iterations of the ugly words, and it still hasn’t panned out, so I’m slightly worried. I have a few questions for Cosmos/IFC that I’m hoping can be answered:

  1. Has anyone else had this issue? Is it possible there was some bug in the fundraiser that could have caused me to not get a valid seed?
  2. If there was no bug, I’m hoping this script can find the real seed - https://github.com/gurnec/btcrecover/blob/master/docs/Seedrecover_Quick_Start_Guide.md#running-seedrecoverpy . It can recover seeds with typos from BIP 39. What I need to know from cosmos - is the original hex cosmos address (used to query balance at fundraiser.cosmos.network) , the same as the the first eth address (because this script can recover eth addresses).
  3. Also, is it the first derived address? Basically this script can confirm an eth address, and if you know an address that is created by the wallet, and what number it was derived at, it will run a lot faster.
  4. How is the cosmos address of today (cosmosaddr1…………) derived? I am looking for the file/module that does this.

Any other advice anyone could give me would be great.

Thanks!

0 Likes

#2

Hey,

in case you just wrote one of your words down wrong and know the cosmos1... address, I wrote a tool for you real quick. It iterates through the entered mnemonic one by one and tries out if a single word changed results in the correct address. The tool is written in Go and open sourced on my Github. If you need any help to build and execute it, hit me up!
No guarantee that this works, it’s just a quick hack. But I generated some mnemonics, exchanged a word and it found the correct one.

Best,
Florian from Staking Facilities

0 Likes

#3

HI it’s possible to write a modified version of that script that will iterate until it finds a seed words for your address.

It’s fairly simple task. You just need to modify the code to generate a public/private keypair using the 44'/118'/0'/0/0 BIP44 path and take RIPEMD160(SHA256(COMPRESSED_PUBLIC_KEY))) and compare the output to your address.

Are you technical enough to implement this?

0 Likes

#4

Hey @zaki,
of course I would be able to advance this to bruteforce more than one word change. It’s a fairly simple task, but I didn’t want to overcomplicate it for this specific use case. If OP or someone else runs into this problem and isn’t able to solve it with one word changed, I’ll happily rewrite this to support multiple words. As long as this suffices for OP & others, I’ll leave it as is. If you know anyone who needs this, just let me know.

Best,
Florian from Staking Facilities

0 Likes

#5

Hey @zaki and @katernoir, thanks for the replies. I’m not sure if Zaki is reffering to the link I posted or what katernoir wrote but yeah, I should be able to implement this change myself. I am going to look at both of the scripts and see what suits my problem best.

I’ll report back once I get through it, hopefully I solve it and I can post some information that could help anyone else in my situation.

If I get stuck I’ll ask in here for guidance.

Once again thanks for your help!

0 Likes

#6

It might be useful if you find the amount in the genesis.json file that matches yours. This way you will know your public key and the other key.

0 Likes

#7

I guess you’re right and Zaki meant your link. Sorry for that, it was already late :smiley: Good luck with your seed. Let us know how this works out!

Best,
Florian from Staking Facilities

0 Likes

#8

Haha, I wrote down one word horribly wrong. The script found the right word in about 2 seconds. Thanks for the help guys!

I had to change a few lines of code in the btc recover script, which took some time to figure out where to put it, but it was really simple.

Hopefully if anyone else has the same problem, they will come across this thread!

2 Likes

#9

Congratulations! Glad to see that this was quickly solvable!

0 Likes