Unable to configure the initial balance

Hello everyone,
When I tried to run a Cosmos node, I followed the instruction at the official documentation (Setting up the keyring | Cosmos SDK). For more details, these are the commands I used:

  1. cosmosd keys add validator --keyring-backend test
  2. VALIDATOR=$(cosmosd keys show validator -a --keyring-backend test)
  3. echo $VALIDATOR (It gave the result cosmos10ngz0gn5gx6glt6vl0q6ntsq5t5dmecpx5wkkr)
  4. cosmosd init node-1 --chain-id 1506
  5. cosmosd add-genesis-account $VALIDATOR 100000000000stake
  6. cosmosd gentx validator 1000000stake --chain-id 1506 --keyring-backend test
  7. cosmosd collect-gentxs
  8. cosmosd start

Finally, I went to http://localhost:1317 and used the balance API (/cosmos/bank/v1beta1/balances/{address}) to get the balance of $VALIDATOR (i.e. cosmos10ngz0gn5gx6glt6vl0q6ntsq5t5dmecpx5wkkr). The result was 0.
However, the Cosmos documentation said that “You should see the current balance of the account you created, equal to the original balance of stake you granted it minus the amount you delegated via the gentx”, so the above result should not be zero.
Anyone please tell me why the balance I got was 0? Did I miss something when I tried to run my own node?